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About Software Copying
Thank you for purchasing SuperLab Pro, an experimental
tool we hope will serve you well.
SuperLab Pro is the result of long, long hours of work.
We’ve put a lot of time into it so you won’t have to. And
we’d like to continue improving it and implementing
your ideas and suggestions.
So please, we plead with you, if you must show SuperLab
Pro to a friend or colleague, do NOT give them the fully
functional version; instead, give them a demonstration
version or our contact information to send them a free
demo. Giving away the fully functional version, in
addition to being unethical and a punishable crime,
results in fewer sales and discourages us from continuing
to support and improve the product.
Thanks again for choosing SuperLab Pro. We wish you
success in your work.

“I had cleaned my bedroom, and went all around
the room. I came up to the couch, and could not
remember whether I had dusted it or not. Since
these motions were habitual and unconscious, I
couldn’t even perceive that it was now
impossible to remember them. So if I had already
cleaned the couch and forgot about it — that is,
if I had acted unconsciously — it was as if I had
never done it.”

— Leo Tolstoy

Chapter 1 - Introduction
Welcome to SuperLab Pro.
SuperLab Pro is a fine tool for setting up and running experiments. With its
various built-in editors, you can interactively set up an experiment that presents
visual stimuli on a monitor, plays auditory stimuli over headphones or speakers,
or interacts with laboratory equipment. Experiments are saved in a text-only file.
SuperLab Pro can collect the data with one millisecond accuracy or better.
Other features in SuperLab Pro let you change the placement of visual stimuli on
the screen, change the screen’s background color, choose from a variety of input
and timing options, and provide feedback to subjects based on either response or
reaction time. And while building your experiment, you can do it all with a
familiar point-and-click user interface.

If You Hate Reading Manuals...
...then please read at least this section.
Using SuperLab Pro, while easy, assumes you are familiar with a graphical user
interface such as Microsoft Windows or the Macintosh, and some standard
techniques such as selecting an item from the menu bar, opening and saving files,
double-clicking, and so forth.
To run an experiment...

If all you will be doing is running experiments already written, using SuperLab
Pro is straightforward. Just run the program, choose Open from the File menu to
load the experiment file, then choose Run from the Experiment menu. That’s it!

But to develop an
experiment...

If you will be developing new experiments, you should be familiar with the
terminology and concepts that SuperLab Pro introduces. It is strongly suggested
you spend some time going through at least the rest of this chapter and the next
one, “SuperLab Pro Basics.” It takes no more than 20 or 25 minutes, and is well
worth the time spent.
Beyond the “SuperLab Pro Basics” chapter, the rest of this manual is mainly for
reference, complemented by the online help file.

Installing SuperLab Pro on Your PC
To install SuperLab Pro on your computer:
1.

Start Microsoft Windows.

2.

Insert the SuperLab Pro distribution diskette into your floppy drive.

3.

From the File menu in either the Program Manager or File Manager, choose
Run.

4.

Type a:\setup (or b:\setup).

5.

Press Enter.

The install program will run. Follow the on-screen instructions, which prompt
you for the optional components you’d like to install (e.g. SuperLab SDK) and the
directory location.
The install program creates a file named “install.log” in your SuperLab directory.
Keep this file; it is necessary if you want to uninstall SuperLab Pro at a later time.

What’s Not in This Manual
Some things are not in this manual but can be found in the online help files that
come with SuperLab Pro. Notably, the experiments’ file format is available only
in electronic form. In addition, the SuperLab Software Development Kit
(SuperLab SDK) is entirely in electronic form. If you have written Windows
software before, you will find that the SuperLab SDK documentation has a
familiar feel to it.
And last but not least, it is much easier to update and distribute documentation
in electronic form than in printed form. So if you think any information is
missing from this manual, check the online help first. Try the following:
1.

In SuperLab Pro, choose “Search for Help on” from the Help menu. A
dialog will appear.

2.

Type “information not” and a topic named “Information Not Found in the
Manual” will be highlighted.

3.

Press the Enter key twice and a list of information not found in the manual
will appear.

If you still cannot find the information you need or feel that a topic of interest has
not been adequately described, please take the time to send us email or call; we
want to hear from you, otherwise the weaknesses in the documentation will
never be improved.
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Cedrus Support
Cedrus provides three communication channels for asking questions, reporting
bugs, or simply telling us what is on your “wish list.”
In general, if you have a question, please check this manual first; you may find
the answer is already in it. In particular, check the table of contents in the
beginning, the index at the end, and the “Frequently Asked Questions” section in
the “More on SuperLab Pro” chapter. Also, check the online help file, accessible
by choosing Contents from the Help menu in SuperLab Pro.
Additionally, you can also check our Web site. The SuperLab Pro support page
has a list of frequently asked questions (FAQs) and we have plans to add
application notes. The URL is ht t p:/ / www.cedrus.com.
By Electronic Mail

This is the preferred method. It allows us to archive your questions and
comments faster and easier, gives us more time to research your question, and it
is available to you anytime of the day or the year. The Internet address is
superlab @ced rus.com. Most questions via electronic mail are usually
answered within 24 hours.

By Telephone

The hours are 10 AM to 5 PM Mountain Standard Time (MST) time. The number
is 1-800-CEDRUS1 (that’s 1-800-233 7871). It is available toll free anywhere in the
United States and Canada. If you are calling from overseas or from the Phoenix,
Arizona, metropolitan area, the number is 1-602-631 9044.
When calling by phone, we can help you best if the telephone is next to the
computer where SuperLab is installed.

By Fax

The number is 1-602-631 9047. Please provide both of your phone and fax
numbers.

The WebAnnounce Service
WebAnnounce is an email notification service. When you subscribe, you will get
occasional email messages about the latest SuperLab Pro news. The URL is
ht t p :/ / www.cedrus.com/ superl ab/ webannounce.ht m. WebAnnounce
is the best way to stay in touch with the latest developments at Cedrus.

Credits
Paying tribute is always a risky endeavor because someone will be unfairly
forgotten. But it would be more unfair not to recognize the ones we do
remember.
Chapter 1 - Introduction
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For the original product idea and continued guidance, thanks to Dr. James
Haxby, Chief of the Section on Functional Brain Imaging, Laboratory of
Psychology and Psychopathology, National Institute on Mental Health; and Dr.
Raja Parasuraman, Director, Cognitive Science Laboratory, The Catholic
University of America.
For the invaluable feedback and enthusiastic support, thanks to Dr. François
Lalonde, Senior Scientist Officer, Laboratory of Psychology and Psychopathology, National Institute on Mental Health; and to Dr. Chris Chase,
Hampshire College.
The list is much longer than that. It includes customers who provided great new
ideas, beta testers who volunteered time and effort, and friends who were
supportive all around. To all of you, thank you.
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Chapter 2 - SuperLab Pro Basics
SuperLab Pro is a powerful yet easy to use tool for setting up and running
experiments. It has several built-in editors that let you setup the experiment
interactively.
In this tutorial chapter, you’ll learn how to create an experiment. The sample
experiment in this tutorial assumes a human subject, but concepts learned are
applicable througout SuperLab Pro. We will use visual stimuli files provided on
the SuperLab Pro distribution diskette. The experiment will be a smaller version
of the Letter Rotation demonstration included on your diskette. Going through
this chapter takes approximately 25 minutes.

To start, run SuperLab Pro. You do that by double-clicking on the program’s
icon in the Program Manager. When the program starts, a window similar to this
next one opens.

This is the main Experiment Editor where all trials are created. The smallest unit
of an experiment is the event, usually a stimulus or a control signal. A trial is a
set of events, and a block is a set of trials. To run an experiment, you must have
at least one block, one trial, and one event.
Note that a selection rectangle is drawn around the list of blocks. To familiarize
yourself with the SuperLab Pro workspace, try the following steps:
Click on the Edit menu. A menu will appear.

Choose the menu item One New Block. This will cause a small dialog to
appear. It’s the Block Editor.
Type “Instructions”.
Click on the OK button. The Block Editor will go away, and “Instructions”
will appear in the list of blocks.
In the main Experiment Editor, click on the list of trials. The selection
rectangle will move from the list of blocks to the list of trials.
Click on the Edit menu again.
Note how some menu items have changed. The item that used to read “One New
Block” now reads “One New Trial”. This is because the Edit menu is a dynamic
menu, meaning that its items change depending on your actions.
Release the mouse button to make the Edit menu go away. We will not create a
trial at this time.

Before we start creating events and trials, we need to tell SuperLab Pro what
responses are to be accepted from the subject. In the case of this Letter Rotation
experiment, it will be the letter B for backward and the space bar for forward. To
start, go to the Experiment menu and choose Responses. The Response Editor
will appear:
In the Response Editor window,
click on the New button. A small
dialog box appears.
To define the space bar as a forward
response, press the space bar once.
Click on the OK button.
Click on the New button again. To
define “B” as a backward response, type the letter B. Everything you type
is converted to uppercase; SuperLab Pro ignores the character case. Click
on the OK button.
We’re done. The space bar and the B character are now defined as responses for
the experiment. You can define up to 64 responses this way, each having from 1
to 11 characters.

Before proceeding any further, let us save what we have done so far. We may
not have accomplished much yet, but it is always a good idea to save, and save
frequently. Choose Save from the File menu. You’ll get a dialog similar to the
following:
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In the edit box at the top, type the name you would like to give to the experiment,
say “firstone.xpt” We suggest you always give your file names the .XPT
extension. For convenience, SuperLab Pro will insert the .XPT extension
automatically if you do not type it, so you can just type “firstone” and the file will
be saved as “firstone.xpt”. When you are ready, click on the OK button and
SuperLab Pro will save the experiment to disk.
There is a fact worth noting here. SuperLab Pro saves its experiments in readable
text files. This means that you do not have to use only SuperLab Pro’s editors;
since the file format is fully described in the online help file, you can use any text
editor, word processor, or spreadsheet program to edit an experiment. And, if
you are handy with programming, you can even write BASIC, Pascal, or C
language programs to generate experiments automatically.

Creating the Events

Back to the experiment; you are now ready to create your first event. In the
Experiment Editor window, click on the list of events to move the selection
rectangle to it, then choose One New Event from the Edit menu. The Event
Editor appears. Do not type anything yet.
An event is the smallest unit of an experiment. It is where you tell SuperLab Pro
what to present to the subject, what response to accept, and how to provide
feedback based on that response. To keep things simple without sacrificing
features, the Event Editor is divided into three “property sheets” (also called
sections) named Input, Feedback, and Event. You switch between the three
property sheets by clicking on the corresponding button.
Click on the Event button to switch to that property sheet. This is where you
control what to present to the subject, and how. Click on the Event Type combo
box; it shows five types of events. Try choosing different types; when you do,
notice how the contents of the Event Editor change automatically depending on
your choice. These items are, in alphabetical order:

Chapter 2 - SuperLab Pro Basics
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Note: the Event Type
combo box may show
more or less than 5 types
of events, depending on
how many event “plug-ins”
you have installed.

❏

Sound File. Allows you to use a .WAV file to play auditory stimuli.

❏

Digital Output. Using this optional feature, you can send pulses or control
digital i/o lines using third party cards such as the Computer Boards’ CIODIO24 or National Instruments LabPC card. This feature is very useful if
you want to interact with or control equipment outside your PC, e.g.
control laboratory apparatus, turn lamps on or off, trigger an MRI machine,
or synchronize two or more different computers.

❏

Inter-Stimulus Interval (ISI). Introduces a waiting period.

❏

Picture File. Allows you to use any .BMP file to draw visual stimuli.

❏

Text. Lets you present simple text stimuli without requiring a bitmap file,
with full control over font, size, and other attributes.

For this first event, we would like to greet the subject with some instructions.
Make sure that the event type selected is Picture File. Click on the File button. A
familiar “open file” dialog appears:

The file we want to open is called “instruct.bmp” and is located in the “tutorial”
directory. Once you have located the “instruct.bmp” file, click on it to select it

8

SuperLab Pro User’s Guide

then click on the OK button.
Now, you are back in the Event Editor dialog. This is how it should look:

The gray rectangle has been replaced by a “mini” view of the picture. In the File
Info area, some information is now displayed about the file you have just opened.
To save you time, SuperLab Pro has also inserted an event name automatically; it
stripped the file extension and converted the first letter to upper case. Complete
the event name to read “Instructions.” If you already had an event name typed,
SuperLab Pro would not have replaced it. Speaking of event names, they must
be unique. Even though a trial and an event can have the same name, no two
events may share the same name. The same rule applies to trial and block names:
no two trials and no two blocks may have the same name.
To see the picture exactly as it will be presented to the subject:
Click on the Preview button.
By default, the picture is centered both horizontally and vertically, and is
drawn at the same size it was created with. Both the position and size can
be edited, but in this experiment we will use SuperLab Pro’s default values.
When previewing, SuperLab Pro displays in the bottom left corner of the
screen the time it took to display the picture.
When done looking at the picture, click the mouse button or press any key.
You should now be back in the Event Editor dialog. Click on the OK button.

Chapter 2 - SuperLab Pro Basics
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In the Experiment Editor, you will find the event we just created, “Instructions,”
listed under “Events” (see picture on the left). Note that it is preceded by a
hollow diamond ( ). More on that in a little bit.
Our tutorial experiment is to contain four visual stimuli in addition to the
instructions screen in the beginning. To proceed, make sure the selection
rectangle is around the list of events then click on the Edit menu and choose
Many New Events. This feature works similarly to One New Event except that
the Event Editor remains on the screen until you click on the Cancel button. This
saves time over having to choose One New Event from the Edit menu every time.
The four picture files to be used as visual stimuli are “f0.bmp,” “lr30.bmp,”
“f180.bmp,” and “rbl60.bmp.” Even though these file names may seem cryptic,
they are not random. The first letter indicates the character to be presented to the
subject (F, L, or R) and the digits indicate the rotation angle of the letter. The
letter B, when present, indicates that the character to be presented is backward.
When creating your own experiments with SuperLab Pro, we suggest you use a
similarly consistent file naming convention.
Once in the Event Editor dialog, proceed as follows. For file “f0.bmp”:
1

Click on the File button. The familiar “open file” dialog opens.

2

Locate the file “f0.bmp” and click on OK. The “open file” dialog goes away.

3

Click on the OK button again. The Event Editor will remain on the screen,
but will now be ready for creating another event.

Stimulus F0

To create the next event for file “lr30.bmp”:

Stimulus LR30

1

Click on the File button to open the “open file” dialog.

2

Locate the file “lr30.bmp” and click on OK. The “open file” dialog goes
away.

3

Click on the OK button again. The Event Editor will remain on the screen.

The next event is “f180.bmp”:

Stimulus F180

1

Click on the File button to open the “open file” dialog.

2

Locate the file “f180.bmp” and click on OK.

3

Click on the OK button again.

The next event is “rbl60.bmp”:
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Stimulus RbL60
(backward)

1

Click on the File button to open the “open file” dialog.

2

Locate the file “rbl60.bmp” and click on OK.

3

Click on the OK button again. The Event Editor will remain on the screen.

You have finished creating the four events. Click on the Cancel button; the Event
Editor will now go away. This is how the Experiment Editor now looks:

Choose Save from the File menu to save your work so far.

Controlling Input

The original letter rotation experiment was designed and built using SuperLab
Pro at the National Institute on Aging in Bethesda, Maryland. As designed,
every letter is supposed to stay on the screen until the subject responds correctly.
With the events created so far, you haven’t setup yet how they interact with the
subject, so you need to that next. In the process, you will learn about two new
ways to use the Event Editor, the same one you used to create the events.
1

In the list of events in the Experiment Editor, click on event F0 to select it.

2

Hold down the Shift key on your keyboard and click on event Lr30.
Holding down the Shift key allows you to make multiple selections.

3

While still holding down the Shift key, click on events F180 and Rbl60 to
select them too. Release the Shift key and mouse button. You should now
have four events selected at the same time.

4

Choose Edit Event from Edit menu.

The Event Editor will appear again, but with one important difference: this time
you are not creating a new event, you are editing four events at the same time.
Any change you make here will affect all the events currently selected. This is a
powerful editing feature, one that you will come to rely on as you become more
experienced with SuperLab Pro.

Chapter 2 - SuperLab Pro Basics
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1

In the Event Editor, click on the Input button to switch to the Input
property sheet.

2

Click on the “Correct key” radio button to select it.

3

Click on OK. The Event Editor will go away, and all four events are now
setup so that the subject has to answer correctly.

So far so good. But there is one thing left to be done: even though you setup all
four events to end only with the correct response, you still have not told
SuperLab Pro what is in fact the correct response.
1

In the list of events in the Experiment Editor, click on event F0. This will
select it and deselect all the others.

2

Choose Edit Event from Edit menu.

3.

Click on the “Correct response” combo box; a list will appear with three
items in it: (none), blank, and B. The first one, (none), means that no
response is currently defined as being the correct one. The next two are the
responses you’ve defined using the Response Editor earlier in this tutorial.
For event F0, the correct response is the space bar. Choose the blank, the
second item in the combo box.

In the upper right corner of the Event Editor dialog, there are two new buttons
that you see for the first time: OK, Next and OK, Previous. In addition to being
handy editing features, these two buttons make it possible to use the Event Editor
in yet another way -- as a way to “browse” through the events.
Let’s continue telling SuperLab Pro what are the correct responses for the
remaining three events:
1

Click on the OK, Next button. SuperLab Pro will record the changes made
to the event being edited and show you the next event to be edited, in this
case Lr30.

2

Click on the “Correct response” combo box and choose the blank, the
second item in the combo box.

3

Click on the OK, Next button. The next event, F180, will appear.

4

Click on the “Correct response” combo box and choose the blank, the
second item in the combo box.

5

Click on the OK, Next button. The next event, Rbl60, will appear.

6

Click on the “Correct response” combo box and choose B.

Finally, click on the OK button; the Event Editor will go away. We have now
finished setting up events for this experiment. Chose Save from the File menu to
save the experiment.
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Creating the Trials

As mentioned earlier, an event is the smallest unit of an experiment, and a trial is
a set of events. A trial may consist of any number of events. However, you
should avoid the common mistake and temptation of including all the events in
one trial.
In the case of this experiment, a trial will have only one event in it, and we will
give it the same name as an event, for simplicity’s sake. To create the five trials:
Click on the list of trials to
move the selection rectangle
to it and choose Many New
Trials from the Edit menu.
In the Trial Editor dialog, you
will find a “Use for feedback
only” checkbox and a
rectangular area where code
values would normally
appear. We’ll come back to
these two options in the next chapter.
In the edit field, type “instructions.” Click on the OK button. The Trial
Editor dialog will record the new trial and be ready to accept a new one.
Type “F0” and click on the OK button.
Type “Lr30” and click on the OK button.
Type “F180” and click on the OK button.
Type “Rbl60” and click on the OK button.
Click on the Cancel button.
That’s it. You have just created five trials. Chose Save from the File menu to save
your work.

Creating a Block

A block is a set of trials, and may contain any number of them. There are no
restrictions nor conventions; feel free to organize your experiment however you
want. At least one block is required to run the experiment, so let’s go ahead and
create one:
Click on the list of blocks to move the selection rectangle to it and choose
One New Block from the Edit menu.
In the edit field, type “block 1.”
Click on the OK button.
That’s it. You have just created a block. Save your work before proceeding

Chapter 2 - SuperLab Pro Basics
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further. At this point, this is how the Experiment Editor window will look:

We have now created all the elements needed for an experiment, but we are not
ready to run it yet. A block is a set of trials, and a trial is a set of events, but how
does SuperLab Pro know which trial contains what events?

The Linking
Process

Writing an experiment with SuperLab Pro is a two-step process. You have just
finished the first step, that of creating the blocks, trials, and events. The next step
is linking.
Linking tells SuperLab Pro which trials are included in a block, and which events
are included in a trial. The best way to explain links is probably to proceed with
an example right away. Keep in mind that, in this experiment, we have only one
event per trial.
1

Click on trial “instructions” to select it. Make sure you click on the name
itself, not the diamond ( ) preceding it.

2

In the list of events, there are hollow diamonds preceding every event
name. Click on the diamond preceding the “Instructions” event. This time,
make sure you click on the diamond itself, not the event name. The
diamond should turn from hollow ( ) to full ( ).

3

Similarly, click on trial “F0” to select it.

4

Click on the hollow diamond preceding the “F0” event. It should toggle
from hollow to full. Stop here for now.

You have just linked two trials to one event each. Trial “instructions” contains
the event “Instructions,” and trial “F0” contains the event “F0.”
This approach to organizing an experiment using links provides flexibility. The
number of events or stimuli per trial does not have to be fixed; it can vary within
the same experiment. Linking also simplifies other user interface aspects of
SuperLab Pro. And finally, links allow the same event to be used in more than
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one trial, thus reducing memory requirements and the time it would otherwise
take you to set up the same event multiple times.
Before linking the remaining three trials, click on trial “instructions,” then click
on trial “F0,” and click on trial “instructions” back again. While doing this, notice
how SuperLab Pro automatically updates the diamonds in the list of events to
reflect which events are members of the selected trial.
We still have three trials to link:
1

Click on trial “Lr30” to select it, then click on the hollow diamond
preceding the “Lr30” event. It should toggle from hollow to full.

2

Click on trial “F180” to select it, then click on the hollow diamond
preceding the “F180” event.

3

Similarly, on trial “Rbl60” to select it, then click on the hollow diamond
preceding the “Rbl60” event.

You have just completed linking all trials to all events. Remember to save your
work.

There is one last step required before we go ahead and run the experiment:
linking blocks to trials. At this point, we have only one block named “block 1,”
but SuperLab Pro does not know which trials are contained in it. The block-trial
links work similarly to trial-event links. In the case of this experiment, all trials
are included in “block 1.” Here is how to proceed:

Tip: holding down the Alt
key works also with trialevent links; it will toggle all
events.

1

Click on block “block 1” to select it.

2

Hold down the Alt key on your keyboard, and click on any of the diamonds
preceding the trial names. Be careful to click on the diamond itself, not the
trial name.

Holding down the Alt key while clicking on a diamond is a SuperLab Pro
shortcut that will toggle all diamonds in the list, not just the one you click on.
Trials in a block will always be presented in the same order as they appear in the
list, regardless of the order that in which you link them with a block.
Congratulations! You have just completed the linking process and are now ready
to run your first experiment. Of course, you did remember to save your work,
didn’t you?

Running the
Experiment

Once the experiment is created, running it is straightforward. From the
Experiment menu (on the menu bar), choose Run. A dialog box appears,
containing some options. These are discussed later in the “SuperLab Pro
Reference” chapter. But for now, leave these options unchanged. Click on the

Chapter 2 - SuperLab Pro Basics

15

Run button.
Next, SuperLab Pro will present you with a familiar “save file” box, asking for
the name of the results file. You can change the suggested file name if you like.
Click on the OK button when ready.
At this point, SuperLab Pro will open a window that covers the entire screen and
start displaying the visual stimuli. You can cancel the experiment at any time by
pressing the F1 key.
When done, SuperLab Pro saves the collected results to disk and removes the
window. If you cancel running an experiment in the middle of it, SuperLab Pro
will still save all the data collected up the point when you canceled.

Congratulations, you have just learned how to use SuperLab Pro. The next
chapter, “SuperLab Pro In Depth,” discusses additional topics. In particular, you
are strongly encouraged to read about SuperLab Pro’s codes before starting to
write your next experiment; they could save you a lot of time.
As for the tutorial experiment you created while going through this chapter, do
not delete it yet. It will be used in the next chapter to learn about other features.
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Chapter 3 - SuperLab Pro In Depth
This chapter discusses additional topics. It builds on the previous one by using
the same sample experiment and tutorial style whenever possible. Unlike the
previous chapter however, you do not have to read this entirely, you can read
only the section of relevance to your needs. For example, if you are interested in
adding feedback to your experiment, see the section “Adding Feedback” only.

The Experiment Editor Window
The main window is where all blocks, trials, and events appear. There are some
useful keyboard shortcuts and features that could speed your work if you are
familiar with them.
Selecting
Multiple List Items

Often, you may need to select more than one block at the same time, or more than
one trial or event.
To select all items in a list, choose Select All from the Edit menu.
To select multiple contiguous items, click on the first one to select it, hold
down the Shift key, then click on the last one. All items between the first
one you clicked on and the last will be selected.
To select “disjoint” items, hold down the Control key while clicking on an
item. This will also deselect currently selected items.
If you have a list item selected, e.g. a block, then choose One New Block from the
Edit menu and create a new block, the new block will be inserted before the
currently selected block. If you want to insert a new block at the end of the list,
make sure no block is selected before you create the new one. The same applies
to trials and events.

Linking Shortcuts

There are some shortcuts you can use when linking. For example, suppose you
have an experiment where every trial consists of 3 events, a mask, a cue, and a
visual stimulus. All the trials use the same mask and the same cue, but a
different stimulus. To speed things, select all the trials in the list then click on the
diamonds preceding the cue event and the mask event. This is much faster then
selecting every trial and linking it individually.
Another shortcut is to hold the Alt key while clicking on a diamond. This will

toggle all the diamonds in the list from hollow to full or vice versa.
Other Editing Features

Common editing functions can all be accessed from the Edit menu. Many have
keyboard equivalents too. Some are obvious, like pressing the Delete key to
delete an item. Others may be a little less obvious, like pressing the Enter key to
edit selected items; double-clicking on an item also allows for editing. You can
also press Tab to move the selection rectangle to the next list or Shift-Tab to move
it to the previous list.
If you try to delete an item referred to elsewhere in the experiment, e.g. an event
linked to trials, SuperLab Pro will inform you and ask you to confirm whether
you want to continue deleting the item. If you do confirm, all references are
automatically removed.
When you create a new item, the new item is appended at the end of the list if no
item is currently selected. If an item is selected, the new item is inserted before
the selected one.

Attaching Codes to Trials
Codes are intended to help you with the post-processing of data collected with
SuperLab Pro. The idea is to create codes, give them values, and attach the
values to trials. When you run the experiment, the collected data is saved as a
plain text file with one line per response. Each line contains the trial number,
event number, answer from the subject, reaction time in milliseconds, an error
code, and the code values attached to the trial. In other words, your data is
already pre-coded!
The codes and code values you create could be any alphanumeric string. In the
following example, we will create two codes, Speed and Rotation. Speed has
three values, fast, medium, and slow. Rotation has 4 values, 0, 90, 180, and -90 (in
degrees).

To create the codes and their values, select Codes from the Experiment menu. A
window similar to the above appears.
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1

Click on the New button to the left. A small dialog appears; type Speed
and then click on OK.

2

Similarly, click on the New button to the left again. Type Rotation and then
click on OK.
You have just created the codes.

3

In the Codes Editor window, click on the code Speed to select it. Hold the
Alt key down on your keyboard, and click on the New button to the right.
A small dialog appears.

4

Type the first code value, fast, and click OK. Note that the small dialog
disappears and comes back right away. This is because you held down the
Alt key before clicking on New. It is a common SuperLab Pro shortcut to
speed data entry.

5

With the small dialog still on the screen, type medium and click OK. Type
slow and click OK. The dialog box reappears. Click on the Cancel button.
You have just created the code values for Speed.

6

In the Codes Editor window, click on the code Rotation to select it. Hold
the Alt key down on your keyboard, and click on the New button to the
right. The small dialog appears.

7

Type 0 (zero) and click OK. The small dialog reappears. Type the other
code values the same way, i.e. type 90 and click OK, type 180 then click OK,
and type -90 then click OK. When done, click on the Cancel button.

You have just completed the creation of the codes and code values. While the
above seems like too many steps, it usually takes less than a minute to create all
the code and code values you need.
Now you are ready to “attach” these code values to trials. You can attach them to
either existing trials or to new ones. Let us take the example of a new trial:
1

In the Experiment Editor window, click on list of trials to move the
selection rectangle to it, the chose One New Trial from the Edit menu. The
Trial Editor appears. Note how it lists all the codes just created.

2

Give the trial a name, say “demo trial.” Assuming this is a medium speed
trial with a picture rotation of 180, click on medium and 180. Click on the
OK button.
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That’s it. You have just finished learning how to create and use codes. It is a
good idea to plan in advance which codes you would like to use with an
experiment, but with SuperLab Pro you can create codes “on the fly” and attach
them to trials any time you want. You can also edit and rename the codes and
their values at any time without having to reassign them to trials. If you try to
delete a code or a code value attached to a trial, SuperLab Pro will issue a
warning. If you confirm the warning message and delete, all reference to the
deleted code are automatically removed from all trials.

Adding Feedback
SuperLab Pro allows you to add feedback in one of five cases: the subject’s
response is correct, the subject’s response is incorrect, there is no response within
a time period you specify, the subject’s reaction time is too quick, or the subject’s
reaction time is too slow. A feedback can be auditory, visual, or both. It is
provided to the subject and then the experiment can either proceed with the next
event or present the same one again.
Adding feedbacks to your experiment is easy. The steps involved are similar in
many ways to setting up trials. In fact, a feedback is an entity very similar to
trials. Here is how to go about adding feedbacks:
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1

In the Experiment Editor, click on the list of events to move the selection
rectangle to it, then chose One New Event or Many New Events from the
Edit menu. Create as many events as you will need to present feedbacks.

2

Click on the list of trials to move the selection rectangle to it, then chose
One New Trial or Many New Trials from the Edit menu. The trial editor
appears. In it, click on the check box “Use for feedback only” and give your
feedback a name, e.g. Good feed or Bad feed.
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Click on the OK button. In the Experiment Editor, the feedback name is
preceded with a delta ( ) instead of the hollow diamond ( ). The delta
indicates a feedback.
3

Link the necessary events to the feedback, i.e. tell SuperLab Pro which
events are included in the feedback you have just created. The linking
process should now be a familiar step; it is identical to how you would link
events and trials.

The linking process completes the creation of the feedbacks. You still need to add
them to the relevant events. It’s a simple process:
1

In the Experiment Editor, click on the list of events to move the selection
rectangle to it, select the event you want to add a feedback to, then chose
Edit Event from the Edit menu. The Event Editor appears.

2

Click on the Feedback button to switch to the Feedbacks property sheet.

To add a feedback to an event, turn on the checkbox for the type of feedback you
want. For example, to add feedback for cases when the response is incorrect,
turn on the checkbox “Incorrect” then chose one of the feedbacks you have
created from the combo box next to that checkbox.
To speed things, you can also select more than one event at the same time, choose
Edit Event from the Edit menu, and add feedbacks to all of them at the same
time.
The Feedback property sheet of the Event Editor is described in more detail in the
“SuperLab Pro Reference” chapter.

Additional Facts
About Feedbacks

The Feedbacks property sheet contains two combo boxes at the bottom of the
dialog that give you control over priority of feedbacks and the flow of the
experiment.
The first combo box gives you control over feedback priority. For example, if you
chose to provide feedback to the subject when the response is both incorrect and
reaction time too slow, you can instruct SuperLab Pro which event takes priority
when both eventualities occur. This combo box is automatically disabled (turned
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gray) when it does not apply.
The second combo box instructs SuperLab Pro what to do after an event has been
presented. It can either proceed with the next event (or the next trial if
necessary), or present the entire trial again. SuperLab Pro ignores this combo box
if the feedback is for correct responses.
Please note that an event that is itself part of a feedback cannot have feedbacks; if
a feedback is set, it will simply be ignored.

Another fact to be aware of is the interaction between a time limit placed on an
event and feedback when there is no response. If you chose to use both features
at the same time, no feedback will be provided if the time limit expires first. On
the other hand, if the feedback’s timeout period occurs before the time limit
expires, the feedback will then be provided.
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Chapter 4 - On Timing And Input
This chapter discusses the crucial issue of timing, how SuperLab Pro does it,
what you can do to help improve it, and other details related to using a particular
input device or timer. Other topics that affect the accuracy of timing are also
discussed here.
At Cedrus, we designed SuperLab Pro to be friendly yet powerful, and we are
trying to keep its manual as clear as possible, eliminating the unnecessary
“computerese” whenever possible. Unfortunately, when discussing timing, we
have to introduce some computer concepts as well as some Windows-specific
information.
Please note also that it is possible to extend SuperLab Pro and build your own
timer and input modules using SuperLab SDK. The documentation for SuperLab
SDK is available on the distribution diskette in electronic form, but we
recommend that you visit our web site for the latest version and information.

☞

If you are serious about timing, it is suggested you read this chapter in its
entirety. No single section in it will give you the whole picture.

Timing Options
SuperLab Pro currently provides two options to perform timing: TickCount and
Multimedia.

TickCount Timer

This is the PC’s “standard” timer; it has been around since the very first IBM PC
introduced in 1981. It gets incremented every 55 milliseconds. This is not a
recommended timer!

Multimedia Timer

With the increasing popularity of multimedia applications in the early 1990s,
Microsoft released the multimedia system extensions, which later became
standard issue starting with Windows 3.1 and later releases. These extensions
include a timer that ticks every 1 millisecond on most machines; SuperLab Pro
will tell you what is the resosultion on your particular machine. For example, on
some IBM ThinkPad models, the Multimedia Timer ticks every 2 milliseconds.

Unless you are using a hardware-based timer, the Multimedia Timer is the one
you should be using for all your experiments.

Input Options
Deciding which input option to use is as important as the choice of timer, since it
is the combination of both that determines accuracy. There are currently several
choices with more being added all the time (visit the Cedrus web site for
updates). Current choices are the keyboard, mouse, Cedrus response boxes, and
4 different i/o card models from two different manufacturers. Support for the
i/o cards is not included with SuperLab Pro.

☞
Generic Keyboard

A current limitation is that SuperLab Pro cannot check for input from the subject
while a visual stimulus is being drawn. This will be remedied in a release of
software and/or hardware.

This is basically any PC keyboard. The timing resolution using the keyboard has
not been tested yet. If you are using SuperLab Pro for research, Cedrus strongly
recommends using an external response box via the serial port or an i/o card.
The Generic Keyboard input module may be allright for teaching purposes, but it
is not recommended for studies requiring accurate reaction time measurements.
The Generic Keyboard allows up to 64 responses, each having from 1 to 11
characters.

Generic Mouse
Buttons
MS Mouse Buttons

These two input modules support the mouse buttons. Each has advantages and
disadvantages. The Generic Mouse Buttons module can use the standard mouse
used everyday but cannot guarantee one millisecond resolution. The MS Mouse
Buttons module requires a second, Microsoft-compatible serial mouse but gives
you one millisecond resolution.
See the online help file for more complete information.

ViaPort

The ViaPort is a low cost i/o card that connects to the computer’s serial port. It
provides unique features that avoid the delay inherent in transmitting
information via the serial port.
The ViaPort is still in development as of this writing. Please visit our web site at
http://www.cedrus.com/hardware for the latest information.

CIO-DIO24 Card
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SuperLab Pro User’s Guide

Support Pack, an add-on product available from Cedrus. This card has 24 lines
that may be used for either input or output; it plugs into a standard ISA slot.
SuperLab Pro supports up to 8 lines for input and 8 lines for output. This card is
accessed very quickly, well under one millisecond. For details, see the Cedrus
web site at http://www.cedrus.com/hardware.
Please see the section “Debouncing Time” below.

National Instruments
Card

SuperLab Pro supports the National Instruments LabPC, PC-LPM-16, and PCTIO-10 card using the LabPC Support Pack Standard Edition, a free add-on product
available from Cedrus. It is available for download from the Cedrus web site at
http://www.cedrus.com/superlab. Click on the “archives” link.
These cards plug into a standard ISA slot. SuperLab Pro supports up to 8 lines
for input and 8 lines for output. For input, the card is accessed very quickly, well
under one millisecond.
Please see the section “Debouncing Time” below.

RB-400 Response Box
RB-600 Response Box

These two input modules support the RB-400 and RB-600 response boxes from
Cedrus. They are high quality, microprocessor-controlled response boxes. The
RB-400 has four pushbuttons and the RB-600 has six. They connect to the
computer using one serial port. Visit the Cedrus web site
(http://www.cedrus.com) or contact us for more information.
The microprocessor in these response boxes automatically takes care of switch
debouncing. Please see the section “Debouncing Time” below for more
information.

Debouncing Time

If you decide to build your own response box, take particular care about the
choice of pushbuttons the subject is going to use. When pressed, almost every
switch “bounces,” that is, closes the electric contact and reopens it several times
for a short period. This is usually too quick to be noticeable, but it does happen.
The better the switch quality, the shorter the bouncing period will be.
To get around this problem, a number of input modules let you set a
“debouncing time,” a period of time during which all input from the subject will
be ignored after a pushbutton is pressed. To illustrate the problem, set the
debouncing time to zero and run an experiment. In the collected data file,
chances are good you will see several records (lines) for each response. Keep
increasing the debouncing time until you no longer see multiple records per
response.
Please note that the debouncing time period is “waited out” only when the
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subject responds incorrectly and the input module has to look for another
response for the same event. If the subject responds correctly and SuperLab Pro
proceeds to the next event, the debouncing time is ignored.
The Cedrus RB-400 and RB-600 response boxes take care of the switch
debouncing themselves.

Recommended
Input Device

The recommended input device is either a response box, mouse, or the ViaPort.
Cedrus will keep looking into ways to obtain better accuracy from the keyboard;
however, early research into this issue has not been very encouraging.

How a Visual Stimulus is Drawn
The section and the rest of this chapter discuss visual stimuli drawing times. It
helps explain some of the variability in drawing times and what you do to help
reduce them.
The section provides a quick introduction to video monitors technology. It will
help you understand why, even though SuperLab Pro’s timers are accurate to
within a millisecond, a visual stimulus is not drawn within a millisecond. Even if
you feel you know enough about the subject, it is a good idea to go through it
quickly to ensure the terminology is consistent in subsequent sections.

Video Monitors
Primer

Video monitors used in today’s computers are a quantum leap improvement over
storage tube displays so common in the sixties and seventies. The smallest unit
of information that can be displayed by a monitor is the pixel, a small dot on the
screen. The word pixel is an abbreviation of “PICture Element.” A monitor
represents its information using rows and columns of pixels that can be turned on
or off at will. These rows and columns are often referred to as a raster.

The illustration above shows a magnified raster. All pixels in it are turned off
except for a few that are cleverly aligned to form the letters a, b, and c, and a line.
When a computer is instructed to draw a line from one point to another, it has to
perform a series of calculations to decide which pixels to turn on. This is referred
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to as rasterization, a computing process that takes time. Rasterizing the same line
twice in a row could take a different amount of time, depending on whether your
computer has a RAM cache. More on that a little later.
From the inside, a video monitor contains a “gun” shooting electrons at the
screen. The inside of the screen has a phosphorous coating. When hit by the
electrons, the phosphorous coating produces light, and a pixel is seen turned on.
By turning enough pixels on, a picture and/or text forms on the screen.
This approach to displaying information provides great flexibility. But there is
one catch: if the gun inside the monitor stops shooting electrons at the pixel
location on the screen, the phosphorous coating will no longer emit light and the
pixel will fade away. To get around this, a computer instructs the electron gun to
shoot at a given location on the screen several times a second, typically 60 to 120
times per second. This operation is known as refreshing, or video refresh, and is
very important to understanding how SuperLab Pro and other software draw
visual stimuli.
Video refreshing raises yet another issue: how does the computer know which
pixels are supposed to be on? As you are well aware, every computer comes
with memory, the famous RAM you keep hearing about. To make video
refreshing a reality, the computer must have video memory. On most modern
computers, video memory is physically different from the main memory. In
some cases, the computer simply sets aside a portion of the main memory. But in
all cases, the status of a pixel on the screen is always remembered in memory.
When refreshing occurs, i.e. when the computer is redrawing the image on the
screen, the electron gun goes from top to bottom, from one side of the screen to
the other. Because of this, the electron gun is often referred to as the refresh beam
or refresh line. One complete scan from top to bottom is known as the refresh
cycle. More cycles per second are better because they result in less flicker and a
better picture. The number of cycles per second is often expressed in Hz
(pronounced Hertz). For example, a 60 Hz video monitor has its image refreshed
sixty times per second.
A bit is the smallest unit of information. It has two states, 0 or 1. For black and
white monitors, only one bit per pixel is needed. For color monitors, we need
more bits per pixels, depending on the maximum number of colors that can be
displayed at any one time. For example, a 16 color monitor requires 4 bits for
each pixel, a 256 color monitor requires 8 bits for each pixel. As you can see, the
more colors you use, the you more video memory is needed. But the highest
price is paid in speed because more colors mean more memory needs to be
manipulated and moved around.
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Video Monitors
and SuperLab Pro

What’s in a Cache?

The problem with drawing a visual stimulus is speed. Based on the discussion
above, the best one can do is draw a stimulus within one refresh cycle. Even if
the computer takes only one or two milliseconds to draw the picture, it will still
take a refresh cycle for the picture to appear. But if a picture takes a long time to
draw, it will be many refresh cycles before the computer is done drawing it. To
help reduce drawing time to just one cycle, try reducing the number of colors
your monitor is set to or reducing the size of your stimuli, if this is an option.
Also, for both the Picture File and Text events, make sure you always use the
offscreen buffering option.

If you already know what RAM cache and font cache are, feel free to skip this
section and go to the next one, “Taking Advantage of Cache.”
Earlier in this section, we mentioned a RAM cache. A cache is usually a big
culprit in introducing variability to the drawing time of a visual stimulus. But
what is it?
A cache is a temporary storage area that speeds access to information. It can be
implemented in many different ways. Let’s take the case of accessing
information from a hard disk. A disk is a mechanical device, always slower than
an electronic one. But programs often access the same parts of a disk. It seems
silly to have to read the same thing over and over again when it can be stored
temporarily in RAM memory and accessed much faster from there. So computer
designers set aside a portion of RAM memory to act as a disk cache, i.e. a
temporary storage area to speed access to the disk. So why does a cache
introduce variability? Because the first time you try to access information, the
computer looks to see if it’s in the cache already. If it is, it fetches it from there; if
it is not, it fetches from the hard disk and stores a copy in RAM. The next time
you try to access the same information and it happens to still be in the cache, the
computer will fetch it from there, and it will do it faster than it did the first time
when it had to go to the disk. The keyword here is “faster,” meaning variable.
Please note that a disk cache does not affect SuperLab Pro’s drawing of visual
stimuli; the only reason it is mentioned here is because it’s the easiest to explain.
There are however two other caches that do affect stimulus drawing: RAM cache
and font cache.
In the example just mentioned, RAM memory is used to speed access to a slower
device, the disk. But what happens if the processor has become so fast (as is the
case today) that even RAM memory itself has become too slow for it? The
solution is to introduce a RAM cache, memory that is physically different (and
several times more expensive) from the rest of the RAM memory. When the
processor tries to access RAM, it looks first in the cache and fetches it from there
if it finds it. If it does not, it accesses the slower RAM.
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If your computer has a RAM cache, you can usually tell by previewing a picture
without using the offscreen buffering option. The second time you preview it, it
is displayed a little faster than the first time.
Remember we uttered the word “rasterization” earlier? We used it to show how
a line is converted from two coordinate points to a series of pixels to be turned
on. A similar rasterization process happens when trying to display fonts. In
Microsoft Windows, there are two main types of fonts: raster and TrueType.
Raster fonts are bitmap representations of characters; every character is basically
a small bitmap. Raster fonts do not have or cause much variability in drawing
time, but have the disadvantage of scaling poorly: they look good only in the
sizes provided by the font designer.
TrueType fonts use straight lines and curves that define the outline of each
character. When wanting to display a character, the computer has to convert
these line and curve definitions to a bitmap, i.e. it has to rasterize the character.
This is a slow process because a lot of math is involved. This bitmap is then
stored in a font cache. The next time the computer tries to draw the same
character, it will rasterize it only if it cannot find its representation in the font
cache.
A font cache introduces the wildest variability. Try creating an event of type Text
and use a TrueType font (e.g. Arial) using a large size, e.g. 96. Turn off the
offscreen buffering option and click on the Preview button. Note the preview
time on the bottom left of the screen, then press any key to go back to the Event
Editor. Now preview again, and you are likely to see a preview time significantly
less than the first one. This is because of the font cache.

Taking Advantage
of Cache

As explained above, a cache can speed things up, but at the cost of introducing a
variability in drawing time. You can greatly reduce the variability by using the
offscreen buffering option whenever available. If you do, you can benefit from
SuperLab Pro’s design which takes maximum advantage of a RAM cache while
reducing variability further, all at the same time. Here is how it works.
Suppose you have a trial that consists of 2 events, the first one is a picture and the
second is a text. Both have offscreen buffering enabled. SuperLab Pro creates the
offscreen buffers just before the trial is about to run. This maximizes the chance
that one or more offscreen buffer will still be in the cache when SuperLab Pro
copies it to the main screen. To increase this likelihood even further, SuperLab
Pro creates the offscreen buffers in reverse order. In the case of our example, the
text (second event in the trial) will be drawn to an offscreen buffer first, then the
picture is drawn offscreen. Most modern Pentium computers have 128 kilobytes
of RAM cache or more. Chances are high that at least one offscreen buffer would
fit in the RAM cache and stay in it long enough to be read back and copied to the
main screen.
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Chapter 5 - SuperLab Pro Reference
This chapter forms a reference to all of SuperLab Pro menus and editors. Let’s
start with the editors and dialogs, in the order you would use to build and run an
experiment.

The Response Editor
A response, in the context of SuperLab Pro, is a possible answer to a stimulus.
For example, an experiment may accept only one of two answers, yes or no; on
the keyboard, this can be represented with the keys Y or N; on a response box,
this can be represented with one of two buttons.
When you chose Responses from the Experiment menu, you get a Response
Editor similar to the one picture below. However, if your input module is other
than the keyboard, the Response Editor may look different. Using the keyboard,
you can define up to 64 responses, each having from 1 to 11 characters. For other
input devices, see the chapter “On Timing And Input.”
The Response Editor allows you to add,
edit, and delete responses for the
experiment. To select a response, simply
click on it.
To add a new response, click on the
New button; the new response is
appended at the end of the list. To
create more than one response faster,
hold down the Alt key while clicking on the New button; this will cause
SuperLab Pro to prompt you for new responses until you click Cancel.
To edit an existing response, select it then click the Edit button, or doubleclick on the response itself. The responses are not case sensitive, meaning
that SuperLab Pro does not distinguish between upper and lower letters.
To delete a selected response, click the Delete button, press the Delete key
on your keyboard, or select Delete from the Edit menu.
Click on OK to confirm the changes or Cancel to ignore them.

If you try to delete a response referred to by an event elsewhere in the experiment, SuperLab Pro will warn you and ask you to confirm whether you want to
go ahead. If you do confirm, all events making use of this response will have
their correct response set to “None,” even if you later click on the Cancel button
to have the changes ignored.

The Codes Editor
SuperLab Pro codes are of no use for the purpose of administering the
experiment itself; they come into play later, once you are through with running
the experiment. The idea is to be able to attach one or more codes to each trial,
and use them later in the analysis of the results.
A code can have a number of values; for example, a code named Difficulty may
have one of three values, easy, medium, or hard. Another code named Cue can
have just two values, valid or invalid.
Taking advantage of codes is a two-step process. One, use the Codes Editor to
define all the codes and their values. Two, edit the trials to attach code values to
them. Later, when you administer your experiment, these code values will
appear in the results file that SuperLab Pro saves.
The following picture illustrates what the Codes Editor looks like. In it, we have
defined the two codes mentioned above, Difficulty and Cue. The codes are listed
on the left, their values on the right:
To create a new code, click
on the New button on the
left.
Tip: if you hold down the
Alt key while clicking on
New, SuperLab Pro will
keep prompting for new
codes or code values until
you click Cancel.

To create a new code value,
select the desired code then
click on the New button to
the right.
To view different code
values, click on the code name itself. In the illustration above, for example,
clicking on the code Cue will automatically list its values on the right side.
To delete a selected code, click the Delete button on the left. This will also
delete all the values associated with it.
To edit an existing code, select it then click the Edit button on the left, or
double-click on the code name itself.
To delete a selected value, click the Delete button on the right.
To edit an existing value, select it then click the Edit button on the right, or
double-click on the value name itself.
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You can edit the codes and their values at any time without having to reassign
them to trials. If you try to delete a code value already referred to by a trial
elsewhere in the experiment, SuperLab Pro will warn you and ask you to confirm
whether you want to go ahead. If you do confirm, all trial references to the code
value will be removed, even if you later click on the Cancel button to have the
changes ignored.
You can create up to 20 codes, and each code can have up to 10 values. The code
name may contain from 1 to 15 characters. A code value can contain from 1 to 7
characters.
For details on how to associate the code values with a trial, see the section
“Attaching Codes to Trials” in chapter 3.

The Block Editor
The Block Editor permits the creation of new blocks or the editing of existing
ones. To create a new block, click on the list of blocks in the main experiment
window to move the selection rectangle, then choose One New Block from the
Edit menu. To edit an existing block, click on it to select it, then either press the
Enter key or choose Edit Block from the Edit menu; you can also double-click on
the block.
The Block Editor lets you change the
block name and trial randomization
parameters.
To create a new block or
change the name of an existing
one, type its name in the edit
field. Block names must be
unique.
SuperLab Pro can randomize trials on a per block basis. It is as simple as
turning on or off the “Randomize trials before running” checkbox
If you turn trial randomization on, SuperLab Pro will need a seed for the
random number generator function. In most cases, you will want
SuperLab Pro to choose its own seed based on time; for that, click on the
“A variable, based on time” radio button. If you want to supply your own
seed, click on the “A constant” radio button and enter any value greater
than 1.
Choosing a constant seed value results in the same random sequence every time.
This feature is typically used in cases when the experimenter has a large subject
population and wants to provide groups of subjects with the same sequence.
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The Trial Editor
The Trial Editor permits the creation of new trials or feedbacks, or the editing of
existing ones. To create a new trial or feedback, click on the list of trials in the
main experiment window to move the selection rectangle, then choose One New
Trial from the Edit menu. To edit an existing one, click on it to select it, then
either press the Enter key or choose Edit Trial from the Edit menu; you can also
double-click on the trial or feedback.
The Trial Editor lets you change the trial name and the code values attached to it.
This is described in the “SuperLab Pro in Depth” chapter.

The Event Editor
The Event Editor permits the creation of new events or the editing of existing
ones. To create a new event, click on the list of events in the main experiment
window to move the selection rectangle, then choose One New Event from the
Edit menu. To edit an existing one, click on it to select it, then either press the
Enter key or choose Edit Event from the Edit menu; you can also double-click on
the event.
The Event Editor is divided into three property sheets (also called sections).
These are Input, Feedback, and Event. You selected the desired property sheet
by clicking on the corresponding button.

The Input Property
Sheet
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The Input property sheet is where you tell SuperLab Pro how the event should
interact with the subject.
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The “Event accepts user input” checkbox determines whether input is
accepted at all from the subject. If you turn it off, SuperLab Pro will
present the event and proceed with the next one.
The “Record and save response” determines whether SuperLab Pro should
save the subject’s response to disk. It will not if this checkbox is turned off.
This feature helps reduce clutter in the collected data file by not recording
responses to certain events like instruction screens or digital output pulses.
There are three ways to terminate the response. The first one is only after a
criterion response. The second is after either a criterion response or a time
limit, whichever occurs first. The third is only after a time limit, even if the
subject responds correctly. Choose the corresponding radio button.
If ending the event involves a time limit, enter what the time limit is, in
milliseconds.
A “criterion response” is the event-ending response, and can be either any
key or only the correct key.
If the criterion response is the correct key, you need to tell SuperLab Pro
what the correct key actually is. You can do that using the “Correct
response” combo box. The first item in that combo box is (none). The
remaining items are responses defined separately using the Response
Editor.

The Feedback
Property Sheet

The Feedback property sheet is where you tell SuperLab Pro how to react to
input from the subject. To create feedbacks, you must do that separately using
the Trial Editor. For an introduction to using feedbacks, see the “SuperLab Pro in
Depth” chapter.

To provide a feedback based on whether the subject’s response is correct,
turn on the “Correct” checkbox then choose the feedback from the combo
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box next to it.
To provide a feedback based on whether the subject’s response is incorrect,
turn on the “Incorrect” checkbox then choose the feedback from the combo
box next to it.
You can provide feedback for cases when the subject remains idle for too
long. To do that, turn on the “No response within” checkbox, enter the
time limit, then choose the feedback from the combo box next to it.
To provide a feedback based on whether the subject’s reaction time is too
quick, turn on the “Less than or equal to” checkbox, enter the time limit,
then choose the feedback from the combo box next to it.
To provide a feedback based on whether the subject’s reaction time is too
slow, turn on the “Greater than” checkbox, enter the time limit, then choose
the feedback from the combo box next to it.
Should SuperLab Pro have to provide a feedback, there are two additional
options to give you more complete control over feedback:
Once a feedback is provided, you can use the “After presenting” combo
box to decide if the same trial should be presented again, or whether you
would like to proceed with the next event.
Suppose you have set up an event to provide feedback when reaction time
is too slow and when the response is incorrect. What if the subject
responds both slowly and incorrectly? The “Feedback Priority” combo box
lets you determine which type of feedback has priority.
These two combo boxes are enabled and disabled automatically based on your
current selection of feedbacks. Generally, you will find it that it makes sense why
a combo box disabled.
However, there is one case where the “After presenting” combo box is disabled
in a way that may not make sense at first. This happens if you choose both the
“Greater than” and the “Less than or equal to” feedbacks. In this particular case,
the “After presenting” combo box is disabled and its value is set to “Proceed
normally.” This is because if you set the combo box to “Present same trial again,”
your experiment will go into an endless loop.

The Event Property
Sheet

The Event property sheet is where you control what to present to the subject and
how. Click on the Event Type combo box; it shows five types of events. When
you select one of them, the contents of the dialog box change. The different types
of events are described below. Check the online help file if the description of an
event type is not found in this manual.
Please note that the Event Type combo box may show more or less types of
events than described here. This is because SuperLab Pro has a “plug-in”
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architecture; events are external programs that “plug” into the main program.
When you first run SuperLab Pro, the program looks in the “superlab\plug-ins”
directory for plug-in modules and loads them.
When you switch to the Event property sheet, additional dialog items may
appear, like the File and Preview buttons. These button are automatically
enabled or hidden based on which type of event you choose.

Event – Picture File
The Picture File event type allows you to display any Microsoft Windows bitmap
(.BMP) file as visual stimulus. Practically every graphic and drawing software
for Microsoft Windows can save in the .BMP file format. Once opened from
within SuperLab Pro, you can control the picture’s position on the screen and
how it is presented. The visual stimulus could be anything: text, graphics, black
and white, color, hand drawn, or digitized.
The Picture File event type consists mainly of two buttons and a thumbnail (mini
view) representation of the bitmap.
To open a bitmap file, click on the File button. A familiar “open file” dialog
appears; locate the bitmap file and click on the OK button.
To preview a bitmap file, click on the Preview button. SuperLab Pro
displays the bitmap exactly as it would be presented to the subject and
shows how long it took to draw at the bottom right of the screen. If you
had the “Draw grid” checkbox turned on, a grid is also drawn.
It is a good idea to preview after you change a bitmap’s size or position on
the screen. When you first run SuperLab Pro, it defaults to centering the
picture both horizontally and vertically on the screen. If you change the
position and/or size, these new values become the default for bitmaps
loaded later.
Editing Position
and Size

Once a bitmap has been opened in SuperLab Pro, you can edit its position and
size without having to go back to the graphics package that created it. Click on
the Pos. & Size button; a dialog similar to the next one appears:
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To have the picture centered horizontally automatically, turn on the
“Center picture horizontally.”
To have the picture centered vertically automatically, turn on the “Center
picture vertically.”
If you do not want the picture centered automatically either horizontally or
vertically, you can specify its position on the screen. The position is
measured from the center of the screen to the center of picture, in pixels.
To use the picture’s original dimensions, click on the “Original picture
frame” radio button. SuperLab Pro will show the picture’s dimensions in
pixels in the Picture Size edit fields on the right.
“Scale to fit display” will scale the picture appropriately to fit the entire
screen. SuperLab Pro will show the display’s dimensions in pixels in the
Picture Size edit fields on the right.
To specify any other picture dimension, click on the “My own frame size”
radio button and enter the vertical and horizontal dimensions in the Picture
Size edit fields on the right.

Controlling Picture
Presentation

In addition to position and size, there are other parameters you can control. Click
on the Presentation button; a dialog similar to the next one appears:
If the “Erase screen before
presenting stimulus”
checkbox is checked, the
screen will be erased before
the stimulus is presented. If
unchecked, the screen will
not be erased, allowing you
to overlay multiple visual stimuli on the screen at the same time.
If the “Use offscreen buffering” checkbox is checked, SuperLab Pro will
create an offscreen buffer at run-time, copy the picture to it, than copy the
contents of the offscreen buffer to the screen. Use of this feature is
recommended.
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If the “Make picture background transparent” checkbox is not checked, a
picture drawn on the screen will overwrite everything within its own
frame.
The “Wait nnn ms before starting to draw” feature allows you to add a
lead time before a picture is drawn.

Event – Text
The Text event type allows you to present words or single-line sentences as
visual stimuli. SuperLab Pro gives you control over font, size, style, color, and
position on the screen.
If the “Erase previous screen”
checkbox is checked, the screen will
be erased before the text is presented. If unchecked, the screen will
not be erased, allowing you to
overlay multiple visual stimuli on
the screen at the same time.
If the “Use offscreen buffering” checkbox is checked, SuperLab Pro will
create an offscreen buffer at run-time, draw the text in it, than copy the
contents of the offscreen buffer to the screen. Use of this feature is highly
recommended.

Editing Style

Editing Position

To change any of the text’s attributes,
click on the Style button; a dialog
similar to the one on the right
appears. This dialog is rather
straightforward; four checkboxes give
you control over attributes such as
bold, italic, underline, and strikeout.
Click on the Color button to change the text color. Use the Font and Size combo
boxes to change font and size.

You can edit the text’s position.
Click on the Position button; a
dialog similar to the one on the
right appears.
To have the text centered
horizontally automatically,
turn on the “Center text
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horizontally.”
To have the text centered vertically automatically, turn on the “Center text
vertically.”
If you do not want the text centered automatically either horizontally or
vertically, you can specify its position on the screen. The position is
measured from the center of the screen to the center of text string, in pixels.

Event – Digital Output
SuperLab Pro supports output from i/o
cards and the ViaPort. The Digital Output
modules in the LabPC Support Pack and the
CIO-DIO24 Support Pack function
identically. You can generate a pulse, raise
a digital output line (turn line on), or
lower the line (turn line off).
By convention, on all the supported i/o cards port A is used for input and port B
is used for digital output.
To choose the lines on which pulses will be going out, type it in the edit field.
Valid values are 0 (no lines) to 255 (all lines at the same time). The table below
will help you select the values appropriate for each line:
For line #

The value is

0

1

1

2

2

4

3

8

4

16

5

32

6

64

7

128

To output pulses on more than one line at the same time, simply add the
matching values. For example, to output a pulse on lines 3 and 6, type the value
72 (8+64).
To choose whether you want to generate a pulse, raise a line, or lower a
line, click on the appropriate radio button.
To set the pulse’s duration, type it in.
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If generating more than one pulse, set the inter-pulse interval
In the last edit field, type how many pulses are generated for the event.
Click on the Test button to generate a sample output pulse, raise a line, or
lower a line.
The Source combo box lets you choose which digital output lines you want to
control. The contents of this box will change depending on which Support Pack
you have.

The File Menu
The File menu allows you to perform all file-related functions such as creating a
new experiment, opening an existing one, and saving. Keep in mind that only
one experiment may be loaded at any one time.
The following describes items in the File menu.
New
Creates a new experiment. If there is an experiment currently loaded and
changes made to it have not been saved, SuperLab Pro will remind you to save
the changes.
Open...
Presents the standard “open file” box. Click the OK button to load the
experiment, or Cancel. If there is an experiment currently loaded and changes
made to it have not been saved, SuperLab Pro will remind you to save the
changes.
Loading an experiment takes place in two stages. First, the experiment itself is
read, translated (parsed), and checked for errors. Next, all the picture and sound
files described in the experiment get either loaded into memory or located on the
hard disk, depending on the memory mode you have set in the Preferences
dialog. If, for one reason or another, SuperLab Pro cannot find a given file, it will
present you with the standard open file box again and ask you to locate it.
Close
If you have made changes that are not saved yet, SuperLab Pro will remind you
to save the changes.
Save
Saves changes you made to the experiment currently loaded. If this is the first
time you are saving the experiment and you have not given it a name yet, you
will be presented with the standard “save file” box.
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Save As...
SuperLab Pro presents the standard “save file” box and saves a copy of the
current experiment with a new name you specify. Subsequent uses of Save (as
opposed to Save As...) will save changes you make to this new experiment.
Exit
Exits the program. If there is an experiment currently loaded and changes made
to it have not been saved, SuperLab Pro will remind you to save the changes.

The Edit Menu
The Edit menu performs standard Windows editing functions you are already
accustomed to such as Cut, Copy, and Paste, as well as SuperLab Pro-specific
editing such as creating new items, and editing existing ones.
Many items in this menu are disabled (grayed) or enabled depending on whether
a list item is selected. A list item is a block, a trial, or an event. Cutting, copying,
or deleting a block will also operate on its links. For example, if you cut a block
that has 3 trials linked to it, pasting it back will also restore the links to these 3
trials.
When you Cut or Copy an item, you are limited to a fixed-size 10 kilobytes
buffer, which is plenty for most needs. SuperLab Pro places the contents in the
Clipboard as straight text, in the same format used to save the experiment to disk.
This makes it possible to cut-n-paste not only within SuperLab Pro, but also
between SuperLab Pro and other applications.
The following describes items in the Edit menu.
Undo
Not implemented in this release of SuperLab Pro.
Cut
Makes a copy of the currently selected items and places it in the Clipboard, and
then deletes them.
Copy
Makes a copy of the currently selected items and places it in the Clipboard.
Paste
Pastes the Clipboard contents into the experiment. The Clipboard contents are
pasted in “insert” mode. For example, suppose you used Cut or Copy to place 4
trials in the Clipboard. When you Paste, SuperLab Pro will append the 4 trials
after all the existing ones if no trial is currently selected. But, if at least one trial is
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selected, SuperLab Pro will insert the 4 trials currently in the Clipboard just
before the first selected trial.
Pasting in insert mode makes it possible to use Cut/Copy/Paste to change the
order of items in the experiment.
As discussed earlier, the event, trial, and block names must be unique. For
example, an event can have the same name as a trial, but no two events may have
the same name. To help keep this straight, SuperLab Pro makes sure the items
being pasted have a unique name. It does so by adding a number at the end if
none already exists, or by incrementing the existing one. For example:
Trial 1

gets pasted as

Trial 2

the trial

gets pasted as

the trial1

event 589

gets pasted as

event 590

This method of pasting can also be used to create experiment items quicker. For
example, to create 80 items, create the first one, copy it, and then paste it 79 times.
It is much faster to create the trials this way then to create them individually and
type the name of each.
Delete
Tip: if you hold down the
Alt key while selecting Cut
or Clear, SuperLab Pro
will not confirm the
deletion. Use with care!

Deletes the currently selected items. You can also use the Delete key on your
keyboard.
If you are cutting or deleting an item referred to elsewhere in the experiment,
SuperLab Pro will tell you so and confirm whether you want to go ahead.
Examples are an event linked to a trial or a trial linked to a block.
Since the current release of SuperLab Pro does not implement the Undo feature,
be careful when you delete items.
One New <Item>...
Many New <Items>...
These menu items allow you to add a new block, a new trial, or a new event. The
only difference between the two is that Many New <Items> will keep the relevant
editor on the screen until you click on the Cancel button, thus facilitating the
creation of multiple items.
Edit <Item>...
Edits the currently selected item. For blocks and trials, only one item can be
edited at the same time. For events, you can edit as many events as you want all
at the same time.
Select All
Selects all the items in a list.
Chapter 6 - More on SuperLab Pro
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Select None
Deselects all the items in a list.

The Experiment Menu
The Experiment menu lets you edit miscellaneous aspects of the experiment such
as background color, codes, responses, input method, timing method, and
miscellaneous preferences. You also use the Experiment menu to run an
experiment.
Background Color...
Opens a dialog where you can choose a background color to use when SuperLab
Pro runs an experiment. You can also define custom colors; these are
remembered between sessions.
Codes...
Opens the Codes Editor dialog, explained in detail earlier in this chapter.
Responses...
Opens the Response Editor dialog, explained in detail earlier in this chapter. The
Response Editor may be look different depending on which input module you
choose to use.
Input From...
Lets you choose the method you would like to use to obtain responses from the
subject. The list of available input modules appears in a scrolling list on the left
side of the dialog box. To the right, explanatory text provides some information
about the module.

At the bottom of the dialog box, three buttons and a checkbox are provided: the
familiar OK and Cancel, Options, and Save as default. The Options button is
enabled or disabled automatically depending on the input module you select.
Some input modules will provide a small dialog that lets you set additional
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options when you click on this button.
If the “Save as default” checkbox is checked, it makes the selected input module
the one SuperLab Pro will use next time you create an experiment.
For more complete information on input accuracy, see the chapter “On Timing
And Input.” To develop your own custom input modules, see “SuperLab SDK.”
Timer to Use...
Lets you choose the timer you would like to use to time the responses obtained
from the subject. The list of available timers appears in a scrolling list on the left
side of the dialog box. To the right, explanatory text provides some information
about the timer.
If the “Save as default” checkbox is checked, it makes the selected timer module
the one SuperLab Pro will use next time you create an experiment.

For more complete information on timing accuracy, see the chapter “On Timing
And Input.” To develop your own custom timer modules, see “SuperLab SDK.”
Preferences...
Sets some memory preferences.
These are important in cases
where memory is not plentiful.
By not setting “Keep all events
in memory at all times,” you
can have experiments whose
size becomes practically limited
only by the size of your hard
disk, not the size of RAM.
Check the “Save as default” checkbox if you want the memory mode you set to
become the default for all experiments you create later.
Run...
Runs the experiment. You will first be presented with the dialog below. In it,
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enter the subject’s name. The dialog also contains two checkboxes:
The ”Save collected data” is an
obvious one; if unchecked,
SuperLab Pro will simply not
save any results.
The second checkbox will be
disabled (grayed) if no block
was selected when you chose Run from the Experiment menu. But if you
do have one or more blocks selected, turn on this checkbox to run only the
selected blocks.
Next, if “Save collected data” is checked, you will be presented with a standard
“Save File” box where you need to specify the name of the collected data file.
Click on the OK button to proceed with the experiment.
To cancel an experiment in progress and the input is from the keyboard, press the
F1 key. To cancel an experiment and the input is from another source, hold
down the F1 key while providing that other source with an input. For example, if
input is from a Cedrus RB-400 response box, hold down the F1 key then press
any of the pushbuttons on the response box.

The Help Menu
The Help menu lets you access the online help file and other information.
Contents
Brings up the main online help window. Click on the underlined keywords to go
to a certain topic.
Search for Help On...
Brings up a dialog where you can enter the particular keyword that you are
looking for.
How to Use Help
If you are new to using Windows, chose this menu item for help on how to use
the online help system.
About SuperLab Pro
Displays the current version of SuperLab Pro and other information.

46

SuperLab Pro User’s Guide

Chapter 6 - More On SuperLab Pro
This chapter discusses additional topics of interest. Some are intended for the
curious or technically oriented users. Others have a wider intended audience.

Description of the Collected Results File
SuperLab Pro records all the responses provided by the subjects, whether correct
or not. These are saved in a tab-delimited text-only file.

The above snapshot of the results file has been formatted for presentation’s sake;
the results file you obtain will be plain text.
The first field is the trial name. The second field is the trial number (order). The
reason for this redundancy is because a trial number is easier to process with
statistical software than a name.
The third field is the event number, followed by the subject’s response. In the
snapshot above, responses are either blank (space bar) or the character B.
The fifth field contains an error code. SuperLab Pro generates an NR for no
response, C for correct, an E for error, or an SC for self-correct, meaning the
subject responded previously with a wrong answer then responded with the
correct one. The error code is followed by the reaction time, in milliseconds.
A varying number of fields follow the reaction time; these are the code values
attached to the trial. The number of fields depend on how many codes you have

defined.

Frequently Asked Questions
This section provides some answers to frequently asked questions by SuperLab
Pro users.
Q.

My visual stimulus takes too long to display. Anything I can do about it?

A.

Use offscreen buffering whenever possible.

Q.

Occasionally, when I want to quit SuperLab Pro, it asks me if I want to save the
changes, even though I do not recall making any. How come?

A.

A number of things could cause SuperLab Pro to remind you about saving the
changes. Some are features, others are not.
For example, when loading the experiment and the data files associated with it,
there are times when the program cannot locate a particular data file and it
prompts you for its location. After you have located it, SuperLab Pro records the
new location. This is considered a change that needs to be saved, otherwise you
will be asked to locate the file every time you open the experiment.
Also, anytime you are presented with a dialog box and click on OK instead of the
Cancel button, SuperLab Pro may record it as a change even if you didn’t change
anything.
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Q.

When I open an experiment, SuperLab Pro sometimes says it cannot locate one or
more of the stimuli data files (pictures, sound, etc.). Why?

A.

This could be due to the fact that you moved the data file from a folder or
directory to another, or from one disk to another. Once you have located the
files, SuperLab Pro will record the new location and will not bother you the next
time.

Q.

If two or more visual stimuli use the same picture file, does SuperLab Pro keep
multiple copies of the picture in memory?

A.

No, no matter how many stimuli use a picture file, SuperLab Pro keeps only one
copy in memory. The same holds true for auditory files.
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Microsoft Excel Blues
This section is of interest to those of you using Microsoft Excel to edit SuperLab
Pro experiments directly.
Here’s an experiment fragment we can use as an example in the following
discussion:
#Picture-File
F-1 test L

Aaker.bmp

1158

0

0

265 ...

F-1 test R

Abraham.bmp

1158

0

0

0

...

F-3

Andrews.bmp

1158

0

0

0

...

Amira.bmp

1158

0

0

0

...

acq

F-4 test L

The first parameter of a #Picture-File keyword is the event name, followed by the
stimulus’ file name, path ID, and so forth.
As originally written, SuperLab Pro would read its experiments as is. One day,
one of our beta testers edited the experiment above using a different version of
Microsoft Excel and saved the changes. This is how Excel saved it:
#Picture-File
F-1 test L

"Aaker.bmp"

1158

0

0

265 ...

F-1 test R

"Abraham.bmp"

1158

0

0

0

...

F-3

"Andrews.bmp"

1158

0

0

0

...

"Amira.bmp"

1158

0

0

0

...

acq

F-4 test L

Notice the addition of double quotes on the second field. As it turns out, if a cell
in Excel contains a comma or a double quote, then the entire cell gets doublequoted when saved to disk. Here are some examples:
My Name

gets saved as

My Name

Aaker,N

gets saved as

"Aaker,N"

This "is" it

gets saved as

"This ""is"" it"

"Test!"

gets saved as

"""Test!"""

To work around this “feature,” we modified SuperLab Pro to handle these
quotes. This imposes a restriction on the way you name your events, trials, etc.:
the first letter may not be a double quote.
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Switches for I/O Cards
SuperLab Pro supports the National Instruments’ LabPC, PC-LPM-16, and
PC-TIO-10 i/o cards, and the Computer Boards’ CIO-DIO24 card. These are ISA
cards with 24 digital i/o lines that can be used for either input or output. These
lines are separated into 3 ports, with 8 lines each. SuperLab Pro uses Port A for
input.
If you decide to use one of these cards, Cedrus offers a four-button response box.
But you may still want or need to build your own box. Depending on the card
model, you need to use a 50-pin flat ribbon cable or a DB-37 connector between
your box and the card. The box may contain up to 8 switches, depending on your
experiment’s needs. For each switch, you need a push-button and a 10 kiloohms
(k½) pull-down resistor, wired as illustrated in the diagram on the left.
For more information and diagrams, refer to your National Instruments user
manual.
For the CIO-DIO24 i/o card, use a similar diagram with a lower resistor value,
and connect all unused pins to ground.
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License Agreement
Nearly every software license sold is governed by a license agreement,
sometimes called an End User License Agreement (EULA). Here is the EULA that
governs the use of SuperLab Pro, first in plain English.

In Plain English

It’s really simple:
No two persons may use SuperLab Pro at any one time.
Whenever in doubt, refer to item 1 above.
Our EULA offers more flexibility than other vendors’, many of whom insist that
the software may be installed on one machine only.

Some Frequently
Asked Questions

Can I develop an experiment on one computer and run it on others?
No. You can run SuperLab Pro to develop and collect data on only a single
computer. If you only one to collect data (but not develop and experiment or
modify it) on other computers, Cedrus offers inexpensive "run only" licenses.
Can I install SuperLab Pro on the computer in the office and the one at home?
Yes, provided there is no chance that another person may use it while you’re
using SuperLab Pro at home.

The Complete
Legal Text

END-USER LICENSE AGREEMENT FOR CEDRUS SOFTWARE
IMPORTANT — This End-User License Agreement (“EULA”) is a legal
agreement between you (either an individual or a single entity) and the
PUBLISHER from whom you acquired the software product SuperLab Pro or
SuperLab LT identified above (“SOFTWARE”). The SOFTWARE includes
computer software, the associated media, any printed materials, and any “online”
or electronic documentation. By installing, copying or otherwise using the
SOFTWARE, you agree to be bound by the terms of this EULA. If you do not
agree to the terms of this EULA, Cedrus Corporation (“Cedrus”) is unwilling to
license the SOFTWARE to you. In such event, you may not use or copy the
SOFTWARE, and you should promptly contact Cedrus for instructions on return
of the unused product(s) for a refund.
Software LICENSE

The SOFTWARE is protected by copyright laws and international copyright
treaties, as well as other intellectual property laws and treaties. The SOFTWARE
is licensed, not sold.
1. GRANT OF LICENSE.
This EULA grants you the following rights:
•

Software. You may install and use one copy of the SOFTWARE on a
computer.

•

Storage/Network Use. You may also store or install a copy of the
computer software portion of the SOFTWARE on the computer to allow
your other computers to use the SOFTWARE over an internal network,
and distribute the SOFTWARE to your other computers over an internal
network. However, you must acquire and dedicate a license for the
SOFTWARE for each computer on which the SOFTWARE is used or to
which it is distributed. A license for the SOFTWARE may not be shared
or used concurrently on different computers.

•

Back-up Copy. You may make a single back-up copy of the SOFTWARE.
You may use the back-up copy solely for archival purposes.

2. DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS.
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•

Limitations on Reverse Engineering, Decompilation and Disassembly.
You may not reverse engineer, decompile, or disassemble the
SOFTWARE, except and only to the extent that such activity is expressly
permitted by applicable law notwithstanding this limitation.

•

Separation of Components. The SOFTWARE is licensed as a single
product. Its component parts may not be separated for use on more than
one computer.

•

Single COMPUTER. The SOFTWARE is licensed as a single integrated
product. The SOFTWARE may only be used with a single computer.

•

Rental. You may not rent or lease the SOFTWARE.

•

Software Transfer. You may permanently transfer all of your rights
under this EULA provided you retain no copies, you transfer all of the
SOFTWARE (including all component parts, the media and printed
materials, any upgrades, and this EULA), and the recipient agrees to the
terms of this EULA. If the SOFTWARE is an upgrade, any transfer must
include all prior versions of the SOFTWARE.

•

Termination. Without prejudice to any other rights, Cedrus may
terminate this EULA if you fail to comply with the terms and conditions
of this EULA. In such event, you must destroy all copies of the
SOFTWARE and all of its component parts.
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3. UPGRADES.
If the SOFTWARE is an upgrade from another product, whether from Cedrus or
another supplier, you may use or transfer the SOFTWARE only in conjunction
with that upgraded product, unless you destroy the upgraded product. If the
SOFTWARE is an upgrade of a Cedrus product, you now may use that upgraded
product only in accordance with this EULA. If the SOFTWARE is an upgrade of a
component of a package of software programs which you licensed as a single
product, the SOFTWARE may be used and transferred only as part of that single
product package and may not be separated for use on more than one computer.
4. COPYRIGHT.
All title and copyrights in and to the SOFTWARE (including but not limited to
any images, photographs, animations, video, audio, music, text and “applets,”
incorporated into the SOFTWARE), the accompanying printed materials, and any
copies of the SOFTWARE, are owned by Cedrus or its suppliers. You may not
copy the printed materials accompanying the SOFTWARE. All rights not
specifically granted under this EULA are reserved by Cedrus.
5. DUAL-MEDIA SOFTWARE.
You may receive the SOFTWARE in more than one medium. Regardless of the
type or size of medium you receive, you may use SOFTWARE on only one
computer. You may not use or install the other medium on another computer.
You may not loan, rent, lease, or otherwise transfer the other medium to another
user, except as part of the permanent transfer (as provided above) of the
SOFTWARE.
6. PRODUCT SUPPORT.
Product support for the SOFTWARE is provided by Cedrus or its resellers.
7. U.S. GOVERNMENT RESTRICTED RIGHTS.
The SOFTWARE and documentation are provided with RESTRICTED RIGHTS.
Use, duplication, or disclosure by the Government is subject to restrictions as set
forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer
Software clause at DFARS 252.227-7013 or subparagraphs (c)(1) and (2) of the
Commercial Computer Software—Restricted Rights at 48 CFR 52.227-19, as
applicable. Manufacturer is Cedrus Corporation/532 E. Maryland Ave/Suite
B3/Phoenix, AZ 85012.
8. LIMITATION OF LIABILITY.
Under no circumstances and under no legal theory, tort, contract, or otherwise,
shall Cedrus, its suppliers, or resellers be liable to you or any other person for
any indirect, special, incidental, or consequential damages of any character
including, without limitation, damages for loss of goodwill, work stoppage,
computer failure or malfunction, or any and all other commercial damages or
Chapter 6 - More on SuperLab
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losses. In no event will Cedrus be liable for any damages in excess of the amount
Cedrus received from you for a license to the SOFTWARE, even if Cedrus shall
have been informed of the possibility of such damages, or for any claim by any
other party. This limitation of liability shall not apply to liability for death or
personal injury to the extent applicable law prohibits such limitation.
Furthermore, some jurisdictions do not allow the exclusion or limitation of
incidental or consequential damages, so this limitation and exclusion may not
apply to you.
9. HIGH RISK ACTIVITIES.
The SOFTWARE and the output produced by the SOFTWARE is not faulttolerant and is not designed, manufactured or intended for use or resale as online control equipment in hazardous environments requiring fail-safe
performance, such as in the operation of nuclear facilities, aircraft navigation or
communication systems, air traffic control, direct life support machines, or
weapons systems, in which the failure of the SOFTWARE could lead directly to
death, personal injury, or severe physical or environmental damage ("High Risk
Activities"). Cedrus and its suppliers specifically disclaim any express or implied
warranty of fitness for High Risk Activities.
10. WAIVER OF RESPONSIBILITY FOR MISUSE.
The SOFTWARE can process copyright material and has no way of knowing if
such processing is in breach of copyright law. You agree that it is your
responsibility to ensure that you only process material for which you own or
have licensed the copyright and, further, to indemnify and hold harmless Cedrus
from any claim whatsoever relating to your improper use of the SOFTWARE to
process copyright materials.
11. MISCELLANEOUS.
This EULA represents the complete agreement concerning this license. The
acceptance of any purchase order placed by you is expressly made conditional on
your assent to the terms set forth herein, and not those in your purchase order. If
any provision of this EULA is held to be unenforceable, such provision shall be
reformed only to the extent necessary to make it enforceable. This EULA shall be
governed by American law in the State of Arizona (except for conflict of law
provisions). The application the United Nations Convention of Contracts for the
International Sale of Goods is expressly excluded.
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Index
—C—
Clear. (See Delete)
Close, 41
Codes
attached to trials, 19, 47
delete, 20, 32
edit, 20
editor, 18, 32, 44
new, 18, 32
using, 18–20
value, 19, 32
Collected data
post-processing, 18
save, 16, 18, 32, 46, 47
Color switching. (See Instant Switching)
Copy, 42
Cut
selected item, 42

Experiment File
.xpt extension, 7

—F—
Feedback, 13, 17

—I—
Input, 23–26, 44, 46, 49
Internet, 3

—M—
Microsoft Excel. (See Excel)
Multimedia Timer, 23–24

—N—
National Instruments, 25, 49

—O—
—D—
Debouncing time, 25
Delete
code, 20, 32
code value, 20, 32
response, 31
selected item, 43
Digital output, 49

—E—
Excel, 48
Experiment
file format, 48
loading, 1, 41, 48

Offscreen buffering, 38, 39
Open
experiment, 41, 48
picture file, 48

—P—
Parallel Port, 24
Paste, 42
Picture
display time, 9
drawing, 27
file, 10, 41, 48
position, 9
size, 9

Programming, 7

RB-600, 25
Results File. (See Collected data)

—Q—
—S—

Quit, 41, 48

—R—
RB-400 Response Box, 25
RB-600 Response Box, 25
Reaction time. (See Timing)
Refresh. (See Video refresh)
Response
character case, 6
collected, 47
correct, 20
defining, 6
delete, 31
edit, 31
editor, 6, 31, 44
input device, 44
new, 6, 31
timing, 45
response boxes
RB-400, 25

56

SuperLab Pro User’s Guide

Save
collected data, 18, 32, 46, 47
Excel file, 48
experiment, 6, 7, 13, 41, 48
Sound, 39
Support, 3
Switches, 25, 49

—T—
Timing, 45

—U—
Uninstall SuperLab, 2

—V—
Video refresh, 27
Visual stimulus, 5, 10, 16, 20, 27, 48

