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Support  Arrow Forward  RB-x40  Arrow Forward  Troubleshooting

Known Issues

When in Keyboard mode, response pad prevents Windows from starting up.

Symptom

On some Windows PCs, depending on the BIOS settings, the response pad prevents the PC from completing the startup process.

Solution

If adjusting the BIOS settings is not an option, a workaround is to follow these steps:

1. Set your RB-x40 response pad to Standard mode (DIP switch 1 in the down position).

2. Download the “XID to Keyboard Mode” utility.

3. Install this utility program to run automatically on startup.

This way, the response pad is ignored by the PC during booting, and is put automatically in Keyboard mode afterwards.

Cause

Heads up: this is a bit technical.

USB keyboards have the option to include what they call a “boot interface”. Normally the host operating system loads the HID driver, looks for HID devices (eg. keyboard) and then loads the HID-Keyboard driver. The “boot interface” will provide a limited functionality keyboard operation prior to the HID drivers being loaded so that you can do BIOS setups, etc.

The host system is supposed to check this flag and, if it’s cleared (as it is in RB-x40), ignore the device until the OS proper is loaded. It appears that changing the BIOS setting to enable Fast Boot/USB Optimization skips over that step, and this can cause issues if the machine boots to DOS, if there are multiple boot options, or Windows Safe mode. 

Response pad occasionally “resets” as if it was unplugged and replugged.

Symptom

In RB-x40 response pads that shipped in 2017 or earlier, users would sometimes experience unexpected “resets” that look as if the response pad had been physically unplugged and replugged.

Note:

If the response pad has never worked with your computer, then most likely the USB driver has not been installed yet.

Solutions

This issue happens mainly when the response pad is connected to a USB hub instead of directly to the computer. There are two possible solutions.

1.

Connect the response pad directly to your computer. Using an unpowered USB hub causes a voltage drop that results in a reset. Even though the RB-x40 is capable of running at a much lower voltage, it is designed to disconnect when the voltage drops. You may be already familiar with standalone USB hubs, but any device that offers extra USB ports (other than the computer itself) contains a built-in USB hub, e.g. keyboards and many monitors.

2.

Standalone Hubs

Devices With Built-in Hubs

If you must use a USB hub, it will need to be a powered model, i.e. uses an AC adapter. Please note that some USB hubs that are built into LCD monitors are unpowered even though the monitor itself is not lacking power.

Send the response pad(s) back to Cedrus and we will implement the fix, even if it’s past the warranty period; send us an email to get started.

Cause

The RB-x40 added a chip that is meant to monitor the voltage being delivered to the unit via USB. To avoid malfunction and protect the response pad should the voltage level drop too much, this chip resets the main microprocessor.

Unfortunately, unpowered USB hubs do precisely that: drop the voltage level. They take the power that’s being delivered from the computer and divide it in order to provide additional USB plugs. The hardware-level solution is to remove this chip. The response pads are designed to function at lower voltage levels, and this chip was an unnecessary feature after all.

Our other products, c-pod, Lumina and StimTracker, are not affected by this issue. c-pod does not contain this reset chip feature. The other two are powered devices, i.e. have their own power supply and are not dependent on the power supplied by the USB cable. 

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